5 Comments

  1. stecks
    4th January 2019 @ 1:25 pm

    How much…
    My first scooter didn’t cost that much…
    Second hand Li 150 in 1966
    Victor Meldrew is my middle name

  2. noble1969
    2nd June 2019 @ 4:01 pm

    Fitted this set from SIP as shown in the ScooterWest video , I have the running lights OK. But all four indicators flash. Least it’s better than the Moto Nostra set from SC that were poor quality and wired wrong. Still waiting for replies from the companies.

    • Ralf Roller
      5th June 2019 @ 10:03 am

      Hi Noble, the SIP kits fit perfectly into the frame and wiring is easy. If you have problems however i can think of 2 things:
      – have you used the relay we supply? The original relay will not work
      – have you buyed the right set? There is one until year 2013 models and another from 2014 models

      Please check. If you still have problems best you contact us directly as we are not looking here regularily. Greetings Ralf

  3. scooter center Ulf
    4th June 2019 @ 4:04 pm

    Hi noble1969, I am afraid that you were not happy with the Moto nostra indicators. Please let me know when you bought these as we had a second batch with some improvements
    Piaggio has two ways of connecting the cables on the rear indicators. Using a bulb it does not matter but with LED indicators problems on the frame number ZAPM45/2 can occur. We had only issues on these frame numbers as the LED indicators of other brands have with the other wiring. Please contact me by ulf@scooter-center.com so we can sort that out. Many thanks

    • noble1969
      4th June 2019 @ 8:33 pm

      Forwarded the receipt , mine’s a 2009 300

Leave a Reply